Excel Formel - Alter berechnen

Wie der Titel dieses Beitrags schon sagt, wollen wir hier das Alter von Personen, mit Excel, berechnen. Am Einfachsten geht das, wenn wir eine Datedif - Formel verwenden. Auf solche Datedif - Formeln wird immer wieder hingewiesen - notwendig ist das aber nicht. Aus diesem Grund zeige ich euch hier auch eine Alternative auf.

Wie bereits erwähnt ist es am Einfachsten mit Datedif das Alter zu berechnen. Wir werden hier nicht auf die Funktion selber eingehen, sondern uns nur ein Beispiel dazu ansehen. Wer sich über die Datedif - Funktion selber informieren möchte, der kann das unter diesem Link machen: klick

 

Beispiel 1:

  A B
1 Geburtsdatum Alter
2 23.09.1967 Alter: 40 Jahre 8 Monate 2 Tage

 

Formeln der Tabelle
Zelle Formel
B2 ="Alter: " & DATEDIF(A2;HEUTE();"y") &" Jahre "&DATEDIF;(A2;HEUTE();"ym")& " Monate "&WENN;(TAG(A2)<=TAG(HEUTE());TAG(HEUTE())-TAG(A2);TAG(HEUTE())+TAG(DATUM(JAHR(A2);MONAT(A2)+1;1)-1)-TAG(A2))&" Tage"

 

Nun folgt ein Beispiel ohne die Datedif - Funktion in Anspruch zu nehmen. Diese Variante ist zwar etwas komplizierter, bewirkt aber im Grunde das selbe.

 

Beispiel 2:

  A B C D
1 Geboren Datum heute? Alter gerundet
2 29.02.2000 28.02.2001 0,99931554 0
3 01.03.2000 29.02.2004 3,99726215 3
4 29.02.2000 01.03.2004 4,00273785 4
5 28.02.2002 28.02.2004 2 2
6 29.02.2000 29.02.2004 4 4

 

Formeln der Tabelle
Zelle Formel
C2 =WENN(ODER(GANZZAHL((JAHR(B2)-JAHR(A2))/4);(B2-A2)/365,25<1);(B2-A2)/365,25;(B2-A2)/365)
D2 =ABRUNDEN(WENN(ODER(GANZZAHL((JAHR(B2)-JAHR(A2))/4);(B2-A2)/365,25<1);(B2-A2)/365,25;(B2-A2)/365);0)
C3 =WENN(ODER(GANZZAHL((JAHR(B3)-JAHR(A3))/4);(B3-A3)/365,25<1);(B3-A3)/365,25;(B3-A3)/365)
D3 =ABRUNDEN(WENN(ODER(GANZZAHL((JAHR(B3)-JAHR(A3))/4);(B3-A3)/365,25<1);(B3-A3)/365,25;(B3-A3)/365);0)
C4 =WENN(ODER(GANZZAHL((JAHR(B4)-JAHR(A4))/4);(B4-A4)/365,25<1);(B4-A4)/365,25;(B4-A4)/365)
D4 =ABRUNDEN(WENN(ODER(GANZZAHL((JAHR(B4)-JAHR(A4))/4);(B4-A4)/365,25<1);(B4-A4)/365,25;(B4-A4)/365);0)
C5 =WENN(ODER(GANZZAHL((JAHR(B5)-JAHR(A5))/4);(B5-A5)/365,25<1);(B5-A5)/365,25;(B5-A5)/365)
D5 =ABRUNDEN(WENN(ODER(GANZZAHL((JAHR(B5)-JAHR(A5))/4);(B5-A5)/365,25<1);(B5-A5)/365,25;(B5-A5)/365);0)
C6 =WENN(ODER(GANZZAHL((JAHR(B6)-JAHR(A6))/4);(B6-A6)/365,25<1);(B6-A6)/365,25;(B6-A6)/365)
D6 =ABRUNDEN(WENN(ODER(GANZZAHL((JAHR(B6)-JAHR(A6))/4);(B6-A6)/365,25<1);(B6-A6)/365,25;(B6-A6)/365);0)

 

Wir nutzen Cookies auf unserer Website. Einige von ihnen sind essenziell für den Betrieb der Seite, während andere uns helfen, diese Website und die Nutzererfahrung zu verbessern (Tracking Cookies). Sie können selbst entscheiden, ob Sie die Cookies zulassen möchten. Bitte beachten Sie, dass bei einer Ablehnung womöglich nicht mehr alle Funktionalitäten der Seite zur Verfügung stehen.