Excel Formel - Datum vor 1900

Excel kann nicht einfach so ein Datum vor 1900 darstellen. Woran liegt das? Excel rechnet nicht mit einem Datum, sondern nur mit Zahlen. Ein Datum vor dem 00.01.1900 wäre eine negative Zahl (Dieses nicht existierende Datum ist die Zahl 0) und mit diesen negativen Zahlen kann Excel einfach nicht umgehen. So kommt es, dass wir uns wieder einmal mit Tricks helfen müssen.

 

Im ersten Beispiel zeige ich Euch wie man sich aus einer Jahreszahl, vor dem Jahr 1900, ein Datum zur Erstellung eines Kalenders basteln kann.

 

  A B C
1 gewünschtes Jahr    
2 1645    
3     01.01.1645
4     02.01.1645
5     03.01.1645

 

Formeln der Tabelle
Zelle Formel
C3 =WECHSELN(TEXT(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C3)-3;"TT.MM.JJJJ");JAHR(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C3)-3);$A$2)
C4 =WECHSELN(TEXT(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C4)-3;"TT.MM.JJJJ");JAHR(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C4)-3);$A$2)
C5 =WECHSELN(TEXT(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C5)-3;"TT.MM.JJJJ");JAHR(VERKETTEN("01.01.";$A$2+2000)+ZEILE(C5)-3);$A$2)

 

Im zweiten Beispiel seht Ihr wie man eine Differenz in Tagen, bei einem Anfangsdatum und einem Enddatum, berechnet:

 

  A B C D
1 Anfangsdatum: 01.01.1800   365
2 Enddatum: 01.01.1801    

 

Formeln der Tabelle
Zelle Formel
D1 {=SUMME(TEXT(WECHSELN(TEXT(B1:B2;"T.MM.JJJJ");".";)+2000;"00-00-0000")*{-1;1})}
Enthält Matrixformel:
Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

 

 

Diese Formel können wir auch umbauen, damit wir das Alter in Jahren berechnen können:

 

 

  A B
1 geboren: 1.01.1600
2 verstorben: 1.01.1650
3    
4 Alter: 50

 

Formeln der Tabelle
Zelle Formel
B4 {=SUMME(TEXT(WECHSELN(TEXT(B1:B2;"T.MM.JJJJ");".";)+2000;"00-00-0000")*{-1;1}/365,25)}
Enthält Matrixformel:
Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.