Excel Formel - Letzter Freitag im Monat

Nehmen wir einmal an, dass ihr immer am letzten Freitag eines Monats einen Termin habt. Mit Excel haben wir die Möglichkeit diesen zu berechnen und diesen sogar in einen Kalender eintragen zu lassen. Es folgen von daher 2 Excel Beispiele, welche uns den letzten Freitag berechnen.

 

Beispiel 1: In diesem Excel Beispiel geht es nur darum, dass uns das Datum des letzten Freitags angezeigt wird. Wir geben dazu ein Datum ein und Excel sagt uns, auf welchen Tag der letzte Freitag fallen würde:

  A B
1 Eingabe Datum letzter Freitag im Monat ist
2 01.06.2008 27.06.2008

 

Formeln der Tabelle
Zelle Formel
B2 =WENN(WOCHENTAG(MONATSENDE(A2;0);2)>=5;MONATSENDE(A2;0)-WOCHENTAG(MONATSENDE(A2;0);2)+5;MONATSENDE(A2;0)-WOCHENTAG(MONATSENDE(A2;0);2)-2)

 

Beispiel 2: Nun wollen wir in einem Excel Kalender einen Termin, hier ist es der Sperrmüll, am letzten Freitag eines Monats eintragen lassen. Logisch ist, dass wir uns erst einmal ein Kalender - Grundgerüst gebastelt haben. Darauf kann ich aber nicht an dieser Stelle eingehen. Verkürzt sieht das dann so aus:

  A B C
1 Am letzten Freitag im Monat kommt der Sperrmüll
2 23.05.2008 Fr  
3 24.05.2008 Sa  
4 25.05.2008 So  
5 26.05.2008 Mo  
6 27.05.2008 Di  
7 28.05.2008 Mi  
8 29.05.2008 Do  
9 30.05.2008 Fr Sperrmüll
10 31.05.2008 Sa  

 

Formeln der Tabelle
Zelle Formel
B2 =A2
C2 =WENN(WENN(WOCHENTAG(MONATSENDE(A2;0);2)>=5;MONATSENDE(A2;0)-WOCHENTAG(MONATSENDE(A2;0);2)+5;MONATSENDE(A2;0)-WOCHENTAG(MONATSENDE(A2;0);2)-2)=A2;"Sperrmüll";"")
B3 =A3
C3 =WENN(WENN(WOCHENTAG(MONATSENDE(A3;0);2)>=5;MONATSENDE(A3;0)-WOCHENTAG(MONATSENDE(A3;0);2)+5;MONATSENDE(A3;0)-WOCHENTAG(MONATSENDE(A3;0);2)-2)=A3;"Sperrmüll";"")
B4 =A4
C4 =WENN(WENN(WOCHENTAG(MONATSENDE(A4;0);2)>=5;MONATSENDE(A4;0)-WOCHENTAG(MONATSENDE(A4;0);2)+5;MONATSENDE(A4;0)-WOCHENTAG(MONATSENDE(A4;0);2)-2)=A4;"Sperrmüll";"")
B5 =A5
C5 =WENN(WENN(WOCHENTAG(MONATSENDE(A5;0);2)>=5;MONATSENDE(A5;0)-WOCHENTAG(MONATSENDE(A5;0);2)+5;MONATSENDE(A5;0)-WOCHENTAG(MONATSENDE(A5;0);2)-2)=A5;"Sperrmüll";"")
B6 =A6
C6 =WENN(WENN(WOCHENTAG(MONATSENDE(A6;0);2)>=5;MONATSENDE(A6;0)-WOCHENTAG(MONATSENDE(A6;0);2)+5;MONATSENDE(A6;0)-WOCHENTAG(MONATSENDE(A6;0);2)-2)=A6;"Sperrmüll";"")
B7 =A7
C7 =WENN(WENN(WOCHENTAG(MONATSENDE(A7;0);2)>=5;MONATSENDE(A7;0)-WOCHENTAG(MONATSENDE(A7;0);2)+5;MONATSENDE(A7;0)-WOCHENTAG(MONATSENDE(A7;0);2)-2)=A7;"Sperrmüll";"")
B8 =A8
C8 =WENN(WENN(WOCHENTAG(MONATSENDE(A8;0);2)>=5;MONATSENDE(A8;0)-WOCHENTAG(MONATSENDE(A8;0);2)+5;MONATSENDE(A8;0)-WOCHENTAG(MONATSENDE(A8;0);2)-2)=A8;"Sperrmüll";"")
B9 =A9
C9 =WENN(WENN(WOCHENTAG(MONATSENDE(A9;0);2)>=5;MONATSENDE(A9;0)-WOCHENTAG(MONATSENDE(A9;0);2)+5;MONATSENDE(A9;0)-WOCHENTAG(MONATSENDE(A9;0);2)-2)=A9;"Sperrmüll";"")
B10 =A10
C10 =WENN(WENN(WOCHENTAG(MONATSENDE(A10;0);2)>=5;MONATSENDE(A10;0)-WOCHENTAG(MONATSENDE(A10;0);2)+5;MONATSENDE(A10;0)-WOCHENTAG(MONATSENDE(A10;0);2)-2)=A10;"Sperrmüll";"")
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Weitere Informationen Ok