Zahlen in Worte

Eine solche Tabelle wird wohl nur auf der Arbeit benötigt. Es geht dabei darum Zahlbeträge in Worte umzuwandeln.

 

Tabelle1

  A B C D E
1 eins
zwei
drei  millionen  vier
fünf
sechs  tausend  sieben  hundert  acht  zehner  neun
einer +  
 00/100 €
2 Geldbetrag hier eingeben: Hilfszeilen zur Berechnung
3 123.456.789,00 € 12345678900 1 eins  
4 Gültig bis: 999.999.999,99€   2 zwei  
5 Beispiel für http://ms-excel.eu
(geht wieder onlie)
  3 drei millionen
6   4 vier  
7   5 fünf  
8   6 sechs tausend
9   7 sieben hundert
10   8 acht zehner
11   9 neun einer +
12        
13       00/100 €

 

Formeln der Tabelle
Zelle Formel
A1 =D3&" "&E3&" "&D4&" "&E4&" "&D5&" "&E5&" "&D6&" "&E6&" "&D7&" "&E7&" "&D8&" "&E8&" "&D9&" "&E9&" "&D10&" "&E10&" "&D11&" "&E11&" "&D12&" "&E12&" "&D13&" "&E13
B3 =$A$3*100
C3 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D3 =WENN(ISTFEHLER(VERWEIS(C3;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C3;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E3 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C4 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D4 =WENN(ISTFEHLER(VERWEIS(C4;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C4;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E4 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C5 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D5 =WENN(ISTFEHLER(VERWEIS(C5;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C5;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E5 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C6 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D6 =WENN(ISTFEHLER(VERWEIS(C6;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C6;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E6 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C7 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D7 =WENN(ISTFEHLER(VERWEIS(C7;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C7;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E7 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C8 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D8 =WENN(ISTFEHLER(VERWEIS(C8;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C8;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E8 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C9 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D9 =WENN(ISTFEHLER(VERWEIS(C9;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C9;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E9 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C10 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D10 =WENN(ISTFEHLER(VERWEIS(C10;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C10;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E10 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C11 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D11 =WENN(ISTFEHLER(VERWEIS(C11;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C11;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E11 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;"einer" &" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C12 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D12 =WENN(ISTFEHLER(VERWEIS(C12;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C12;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E12 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)
C13 =WENN(ZEILE()-3<LÄNGE($B$3)-2;RECHTS(LINKS($B$3;ZEILE()-2);1)*1;"")
D13 =WENN(ISTFEHLER(VERWEIS(C13;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun"}));"";VERWEIS(C13;{",";0;1;2;3;4;5;6;7;8;9};{",";"null";"eins";"zwei";"drei";"vier";"fünf";"sechs";"sieben";"acht";"neun
"})
)
E13 =WENN(LÄNGE($B$3)+3-ZEILE()=9;" millionen ";WENN(LÄNGE($B$3)+3-ZEILE()=6;" tausend ";WENN(LÄNGE($B$3)+3-ZEILE()=5;" hundert ";WENN(LÄNGE($B$3)+3-ZEILE()=4;" zehner ";WENN(LÄNGE($B$3)+3-ZEILE()=3;" + ";WENN(LÄNGE($B$3)+3-ZEILE()=1;RECHTS($B$3;2)&"/100 €";"
")
)
)
)
)
)



Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Wir nutzen Cookies auf unserer Website. Einige von ihnen sind essenziell für den Betrieb der Seite, während andere uns helfen, diese Website und die Nutzererfahrung zu verbessern (Tracking Cookies). Sie können selbst entscheiden, ob Sie die Cookies zulassen möchten. Bitte beachten Sie, dass bei einer Ablehnung womöglich nicht mehr alle Funktionalitäten der Seite zur Verfügung stehen.