=WENN(Bedingung;Anzeigen) PDF Drucken E-Mail
Benutzerbewertung: / 87
SchwachPerfekt 
Geschrieben von: Marcus Rose   
Donnerstag, 10. April 2008 um 16:51 Uhr

Mit dem Wort „Wenn“ können wir ja alle etwas anfangen, oder? „Wenn Du mitgehen willst, dann beeile dich, sonst gehe ich alleine!“ Genau so ist auch unsere Formel aufgebaut. Deshalb nennt man sie auch eine Wenn-Dann-Sonst-Formel. Dieses Wenn-Dann-Sonst kann man mehrfach verschachteln: „Wenn Du mitgehen willst, dann beeile dich, wenn es schnell geht, dann warte ich, sonst gehe ich alleine!“ Allerdings können wir mit dieser Formel nur 7 derartige „Wenn’s“ abfragen. Wollen wir achtes „Wenn“ verwenden, muss wieder einmal getrickst werden. Lasst uns aber erst einmal die Formel selber verstehen.

In unserem Beispiel werden wir eine Lampe simulieren. In Zelle A1 verwenden wir die Worte „An“ und „Aus“. In Zelle B1 soll dann geschrieben werden, dass die Lampe an oder aus ist. Wir basteln uns somit für die Zelle B1 bezugnehmend auf Zelle A1 eine Wenn - Formel. Wie müsste diese aussehen? Für unserer Formel benötigen wir eine Bedingung und formulieren diese so: Ist der Inhalt der Zelle A1 gleich „An“, dann schreibe „Die Lampe ist an!“, sonst schreibe „Die Lampe ist aus!“. Als Formel sieht das Ganze so aus:

=WENN(A1="An";"Die Lampe ist an!";"Die Lampe ist aus!")

 

Excel Formel Wenn

Wenn Ihr in Zelle A1 noch nichts eingetragen habt, so könnte Euch schon etwas auffallen. In Zelle B1 wird Euch von Excel jetzt schon gesagt, dass die Lampe aus ist. Woran liegt das? Das liegt daran, dass Excel in diesem Moment nicht einmal auf einen Eintrag in Zelle A1 wartet. Excel sagt: Ist die Zelle A1 leer, so ist die Bedingung, welche wir in unsere Formel geschrieben haben, nicht erfüllt. Damit ist das Thema gegessen. Bei allem was Ihr in Zelle A1 schreibt passiert das, es sei denn Ihr habt wirklich das Wort „An“ geschrieben.

An dieser Stelle können wir der Wenn-Formel unsere zweite Bedingung zuweisen. Denn wollt Ihr wirklich immer diesen Eintrag in der Zelle B1 stehen haben? Wir erweitern unsere Formel also einfach um die Bedingung WENN(A1=“Aus“;“Die Lampe ist aus“;““). Dieses "" bedeutet, dass die Zelle B1 bei Nichterfüllung der Bedingungen leer bleiben soll. Somit sieht unsere Formel so aus:

=WENN(A1="An";"Die Lampe ist an!";WENN(A1="Aus";"Die Lampe ist aus";""))

Nun wird in der Zelle B1 nur noch etwas angezeigt, wenn Ihr die Worte An oder Aus eintragt.

Damit haben wir unsere erste verschachtelte Formel gebastelt.


Zuletzt aktualisiert am Donnerstag, 10. April 2008 um 17:00 Uhr
 
Copyright © 2014 ms-excel.eu. Alle Rechte vorbehalten.
 

Autoren - Login

Werbung

wichtige Links:
http://ms-excel.eu
Hier habt Ihr eine gute Excel Hilfe
Besucherstatistik
Besucher gesamt: 3.224.258
Besucher heute: 120
Besucher gestern: 2.399
Max. Besucher pro Tag: 4.488
gerade online: 1
max. online: 507
counter Statistiken